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Chapter 1 
Introduction to Computers

Introduction 

The introduction of automated computing has radically changed not only how humans solve 
problems but also what kinds of problems we can solve. Computing has changed the world more 
than any other invention of the past hundred years; it is present in nearly all aspects of life.1 

Everyone should study computing because nearly all of the most exciting and important 
technologies, arts, and sciences are, and likely will be, driven by computing. Understanding 
computing helps to illuminate deep insights and questions into the nature of our minds, our 
culture, and our universe.

Computers have been used for medical applications since about the 1950s. The health-care 
industry uses computers for a wide variety of applications, most commonly in electronic medical 
records and clinical decision support systems. Electronic medical records and their associated tools 
enable physicians to integrate data from individual patient histories and related case histories, 
making it possible for them to provide the best possible treatment and care for their patients. 
Personal digital assistant (PDA) or mobile devices are widely used by physicians and nurses for 
tasks such as looking up drug information, reading health journals and textbooks, viewing practice 
guidelines, using medical calculators, and reading and sending email.

Computer systems are useful for hospital administration, from hospital bed tracking and inventory 
control to admissions, facility scheduling, and billing and payroll.

The growth of the Internet has made previously limited services more accessible to both providers 
and patients. It has:

•• enabled the growth of telemedicine, including teleradiology, remote surgery, and patient 
monitoring, expanding access to patients and providers in more remote areas; 

•• provided greater access to peer-reviewed journal articles through online databases, such 
as PubMed; 

•• enabled patients to research their own symptoms through a wide range of websites that 
provide an almost unlimited amount of health information;

1  �Adapted from: Evans, D. (2013) Introduction to Computing, Available from  http://www.computingbook.org/Computing.pdf
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•• made it possible for patients to compare the price, quality, and availability of hospitals and 
doctors;

•• enabled the development of online portals like WebMD, which give patients the options of 
entering and tracking their own medical histories;

•• made it possible for companies to offer websites where critically ill patients and their 
caregivers can post updates on their status and, thus, communicate important information 
to concerned friends and relatives; and

•• with the aid of super computers, helped biomedical research to unravel the mysteries of 
genetic diseases.

The potential role for computers expands beyond the management of electronic records, supplies, 
and facilities. Medical nanotechnology can be used to monitor bodily functions and alert the 
patient or physicians of critical changes in the patient’s health. For example, a tiny chip can be 
implanted in a patient to continuously measure blood-sugar levels and trigger insulin release, as 
necessary. Another technical development is a wearable personal monitoring instrument that 
continuously measures blood pressure, pulse, body fat percentage, and so on. Such data can 
be automatically uploaded wirelessly to a person’s electronic medical record, where a program 
analyzes the data at regular intervals and sends notifications to the individual and their physician if 
something is wrong or abnormal.

Some clinics and physician offices have made it possible for patients to even schedule 
appointments via the Internet, similar to how you would make a hotel reservation. Some offices 
now ask patients to sign in via touch pads, rather than pieces of paper. In the future, we may be 
asked to sit in a special chair that will measure our vital signs and enter them into our electronic 
record. 

The term “health information technology” (Health IT) refers to the electronic systems health care 
professionals—and increasingly, patients—use to store, share, and analyze health information.

Health IT includes:2 

•• Electronic health records (EHRs) – EHRs allow doctors to keep better track of your health 
information and make it easier for your doctor to share information with specialists.

•• Personal health records (PHRs) – A PHR is similar to an EHR, except that you control what 
kind of information goes into it. You can use a PHR to keep track of information from your 
doctor visits, but the PHR can also reflect your life outside the doctor’s office and your 
health priorities, such as tracking what you eat and how much you exercise. Sometimes, 
your PHR can link with your doctor’s EHR.

•• Electronic prescribing (E-prescribing) – E-prescribing allows your doctor to communicate 
directly with your pharmacy. By eliminating the paper prescription, patients are no longer 
responsible for making sure the prescription is given to the pharmacist (eliminating 
potential loss) and pharmacists no longer have to worry about misreading a paper 
prescription (reducing physician to pharmacy communication error).

2  �The three bulleted points are adapted from: Texas Health and Human Services, Health Information Technology. (2016). What is 
Health IT? Available from http://healthit.hhsc.texas.gov/what-health-it
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Computer technology has made medical and clinical reference information easily accessible and 
searchable in any clinical setting. Examples of such reference information include drug databases, 
advisory systems, disease databases, and so on. This is perhaps the most widely accepted clinical 
use of information technology.

Computer Basics

A computer is an electronic device that stores or retrieves data, and processes data to get useful 
information for various purposes. A computer is composed of hardware and software.

Computer Types

Computers are available in a variety of sizes and configurations, such as microcomputers, 
mainframes, and supercomputers.

Microcomputers 

Microcomputers are the most commonly used, as they are the cheapest, most portable, and the 
fastest evolving type of computer available. They are designed for use in homes, offices, and the 
field. Desktop computers, laptops, gaming consoles, sound and navigation systems for cars, PDAs, 
tablets, smartphones, and calculators are all types of microcomputers.

Desktop Computer Laptop Computer

Gaming Console Car Sound and Navigation System

PDA Tablet
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Smart Phone    Calculator

Mainframes

Mainframes can process and store a huge amount of data. They are large 
machines that must be accommodated in secured and air-conditioned 
rooms. Many large organizations—such as health institutions, banks, 
educational institutions, and insurance companies—use mainframes to 
store data and run their daily operations.

Supercomputers

Supercomputers are the most powerful computers, in terms of 
performance and data processing. These computers are used for 
research and exploration purposes because they can hold and 
process massive amounts of data. They are used for personalized 
medicine, space exploration, earthquake studies, weather 
forecasting, nuclear weapons testing, and flight simulation.

Hardware

Hardware is the physical components of a computer, such as the system unit, mouse, keyboard, 
and monitor. Although we will focus our study on the PC (desktop and laptop), its components are 
very similar to the components of other types of computers.

Input Units

The input units are devices that allow users to enter data, information, or commands into the 
computer. These devices include the keyboard, mouse, touchpad, microphone, scanner, joystick, 
light pen, digitizer, bar code reader, and webcam.

Keyboard

The keyboard is a panel of keys used to input data into the 
computer.

Keyboard

 
Mainframe Computer

Super Computers



COMPUTER BASICS

5Chapter 1 

Mouse

The mouse is the most popular pointing device used to 
move a cursor on the computer screen. It usually has two 
buttons,  called the left and the right button, with a wheel 
located between the buttons. Mouse

Touchpad

The touchpad is a pointing device that can translate the 
motion and position of a user’s fingers to a relative position 
on the screen. It is commonly used in laptop computers. Touchpad

Microphone

The microphone is used to input sound and store it in a 
digital form. Although it is commonly a built-in device in 
laptop computers, some people prefer to use an external 
microphone to extend reach or increase the quality of 
sound captured. Microphone

Scanner

The scanner captures hardcopy images and converts them 
to digital form that can be stored on the disk.

Scanner

Controller 

A controller is similar to a mouse. It is mainly used in playing 
computer games to control the movement of an object or 
person. Controller

Light Pen

When the light pen is moved over the monitor screen and 
the pen button is pressed, its photocell-sensing element 
detects the screen location and sends the corresponding 
signal to the computer. Light Pen

Digitizer

The digitizer is also known as graphics tablet. It converts 
graphics and pictorial data into binary inputs, and is used 
for fine works of drawing and image applications.

Digitizer
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Bar Code Reader

The bar code reader scans a bar code image and converts it 
into an alphanumeric value for input into the computer.

Bar Code Reader

Webcam

A webcam is a video camera that feeds or streams images 
in real time to a computer. It is often connected to the 
computer by a USB cable but can be built into computers, 
usually laptops.

Webcam

Output Units

Output units are devices that allow information to display in a human readable form. Such devices 
include printers, speakers and monitors.

  

Monitor

Monitor

The monitor is the main output device of a computer. It 
forms images from tiny dots, called pixels, that are arranged 
in a rectangular form. The sharpness of the image depends 
upon the number of pixels.

Speakers

Speaker

The speaker is the device that outputs sound from the 
computer.

Printer

Printer

The printer is an output device that prints information on 
paper.	  

Projector

Projector

The projector is an optical device that projects an image or 
moving images onto a surface.

Storage Devices

A storage device is any computing hardware or digital media that is used for storing and moving 
data files and objects. It can hold and store information both temporarily and permanently, and 
can be internal or external to a computer. 
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Hard Drive

Hard Drive

A hard drive permanently stores and retrieves data on a 
computer. It consists of one or more platters to which data 
is written using a magnetic head, all inside of an air-sealed 
casing.

Floppy Disk Drive

Floppy Disk Drive

A floppy disk drive enables a user to save data to removable 
diskettes.This type of drive is no longer included in new 
computers. 

 

 Compact Disk

Compact Disc, DVD, and Blu-ray Drive

These plastic discs can store large amounts of data. The 
primary differences between the type of discs are the types 
of technologies in which they can be used and the amount 
of data each can store.

Flash Drive

USB Flash Drive

A USB flash drive is a portable storage device that connects 
to a computer via a USB port. They are an easy way to store 
and transfer information. Flash drives are also known as 
memory sticks, sticks, thumbdrives, or jumpdrives.

Central Processing Unit

The central processing unit (CPU) performs arithmetic and logical operations on data in order to 
convert it into useful information. It is considered the brain of the computer. The CPU performs 
multiple types of data processing operations. It stores data, intermediate results, and instructions 
(program) and controls the operation of all parts of the computer.

Motherboard

The motherboard serves as a single platform to connect all of the parts of a computer together. It 
connects the CPU, memory, hard drives, optical drives, video card, sound card and other ports and 
expansion cards directly or via cables. It is considered the backbone of a computer.

Random Access Memory 

Random Access Memory (RAM) is the internal memory of the CPU for storing data, programs, and 
program results. It is a read/write memory that stores data while the machine is working. As soon 
as the machine is switched off, the data is erased.

Expansion Cards

An expansion card is a board that can be inserted into an expansion slot of a computer 
motherboard to add new functionality to a computer system. But in laptops and new systems, 
built-in functionality and capacity is generally cheapest and preferred. 
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Power Supply Unit

A power supply unit (PSU) converts alternating current electric power to low-voltage direct current 
power for the internal components of the computer. Laptops are capable of running from a built-in 
battery for a period of hours.

 

Case

Case

The computer case encloses most of the components of the system 
such as the motherboard, disk drives, and power supplies and controls 
and directs the flow of cooling air over internal components.

Ports

Ports

The ports are physical docking points through which an external 
device can be connected to the computer.

A port can also be a programmatic docking point through which 
information flows from a program to the computer or over the 
Internet. 

Software

Software is a set of programs designed to perform a well-defined function. A program is a 
sequence of instructions written to solve a particular problem. Examples are operating systems, 
application software, device drivers, and utilities.

Operating System 

An operating system is low-level software that supports a computer’s basic functions, such 
as scheduling tasks and controlling peripherals, managing computer hardware and software 
resources, and providing common services for computer programs. Each computer type has 
a common operating system, such as Unix, Linux, Mac OS, and Microsoft Windows, and each 
operating system has a version based on the features and the environment it will be used in. In this 
manual, we will focus on Microsoft Windows.

Application Software

Application software products are designed to satisfy a particular need of a particular environment. 
All software applications prepared in the computer lab can come under the category of application 
software. In this manual, we will focus on some Microsoft Office applications.

Device Drivers

A device driver is a specific type of computer software that allows communication between the 
computer and an external device, such as a printer, by sending and receiving data.  

Utilities

Utilities are system software designed to help analyze, configure, optimize, or maintain a computer. 
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They are also used to support the computer infrastructure. This is in contrast to application 
software, which is aimed at directly performing tasks that benefit ordinary users.

Units for Measuring Computer Storage or Speed

In computing and telecommunications, the units of measure are different based on what you want 
to measure. 

Data Storage Units

The bit is the smallest unit to measure storage—it is just one binary digit (0 or 1). Eight bits equals 
1 byte. All other units of measure are multiples of a byte:

•• 1 bit (b) 		    0 or 1 = 1/8 of Byte

•• 1 Byte (B) 			   = 8 bits	

•• 1 Kilobyte (K			  = 1024 Bytes

•• 1 Megabyte (MB)		  = 1024 KB

•• 1 Gigabyte (GB)		  = 1024 MB

•• 1 Terabyte (TB)		  = 1024 GB

•• 1 Petabyte (PB)		  = 1024 TB

•• 1 Exabyte (EB)		  = 1024 PB

•• 1 Zettabyte (ZB)		  = 1024 EB

•• 1 Yottabyte (YB)		  = 1024 ZB

Hard Drive Units

Hard drive storage units are measured as data storage units. Factors such as latency and data 
transfer rate, however, can affect hard drive performance. Latency is the delay caused by rotation 
of the disk to bring the required disk sector under the read/write mechanism. It depends on the 
rotational speed of a disk, which is measured in revolutions per minute (rpm). The data transfer rate 
is the rate at which the disk buffers, and it is measured in Mbits per second).

CPU Speed Units

The speed at which a CPU works is measured in hertz (Hz). Modern processors run so fast that 
gigahertz (GHz) is used instead. One gigahertz is one billion cycles per second. Factors that can 
control CPU performance include cache memory and multiple cores.

Network Speed Units

In telecommunications, data transfer rates are commonly measured as multiples of bits per second 
(bit/s) and bytes per second (B/s). For example, the data rates of modern residential high-speed 
Internet connections are commonly expressed in megabits per second (Mbit/s).
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Additional Reading

•• http://alfekrpc.ahlamontada.com/t1082-topic

•• http://egygate.123.st/t1252-topic

•• http://www.al-jazirah.com/digimag/09022003/alteb481.htm

•• http://www.boosla.com/showArticle.php?Sec=Hardware&id=13

•• http://computer.atlas4e.com/

•• http://www.kutub.info/library/book/1884
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Chapter 2
Operating Systems

Introduction 

An operating system is low-level software that supports a computer’s basic functions, such as 
scheduling tasks and controlling peripherals; manages computer hardware and software resources; 
and provides common services for computer programs. An operating system is an intermediate 
interface between users and hardware that can help users access hardware without needing to 
write tough codes. Each computer type has a common operating system, and each operating 
system has a version based on the features and the environment it will be used in. In this manual, 
we will focus on Microsoft Windows.

Operating System Features

Basic features for most operating systems can manage hardware resources, such as memory, 
processor, storage, and internal devices, and provide access to these resources for other software 
applications. In addition, operating systems control the system security and the file management.

Microsoft Windows 10 

Windows 10 (released in 2015) is still the most recent version of the Microsoft Windows operating 
system for PCs and tablets. There have been many different versions of Windows over the years, 
including Windows 8 (released in 2012), Windows 7 (released in 2009), Windows Vista (released in 
2006), and Windows XP (released in 2001).

Windows 10 Desktop 

While Windows 10 has the same 
appearance as the older versions, it 
has many new features.

1.  Windows Background	
2.  Windows Start Button
3.  Windows Task Bar
4.  Windows Notification Area
5.  Windows Date and Time
6.  Windows Action Center

Windows 10 Desktop
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View Basic Information About Your Computer

To check your PC configuration, Right Click on the computer icon on the desktop or in the 
Windows Start Menu and select Properties, or use the WIN + Pause button. On the System window, 
you can view the basic information about your computer, such as Windows edition (which edition 
of Windows 10 is running on the computer), processor, system type (if your Windows is 32-bit or 
64-bit), full computer name, Windows activation (if your Windows 10 is activated or not), and so on.

 

View Basic Information About Your Computer

Tip: You can use WIN + R to start run dialog and type msinfo32 or dxdiag to get more detailed 
system information.

Desktop Icons

To customize your desktop icons on Windows 10, Select Start > Settings > Personalization > 
Themes > Desktop Icon Settings and you can configure your desktop icons. Or, you can use the 
new feature of Windows 10 and just select Start and type in the search area “Desktop Icons,” then 
press Themes and Related Settings.

 

 

       

Desktop Icons
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Display Setting

To open Display Setting, go to your Desktop, right-click your mouse and go to Display Settings. 
Here you can adjust the size of text, applications, and other items as well as change the orientation. 
To change the resolution settings, scroll down this window and click on Advanced Display Settings.

 	  

Display Setting

Virtual Desktops

Windows 10 added this new feature to help organize your desktop. If you keep a lot of apps open 
on your PC, virtual desktops create multiple separate desktops that each can display different open 
windows and applications. You can switch between your applications by pressing the WIN + Tab 
button. You can add a new virtual desktop by pressing Ctrl + WIN + D button. You can also move 
your already opened applications by pressing right click in desktops mode and moving them to 
any new desktop. 

 

Virtual Desktops
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Region and Language Option

You can add multiple languages in Windows 10 by clicking the Windows logo > Settings > Time & 
Language > Region & Language > Add a Language. You can also change the time zone and other 
options.

Region and Language

Installing and Uninstalling Applications

To install an application on Windows 10, just click on the executable file that came with your 
application (setup.exe, install.exe etc.) and follow the prompts. To check your installed application 
or to uninstall it, open the Start Menu > Settings > System > Apps & Features from the left pane. If 
you wish to uninstall the application, select it and click the Uninstall button that appears. Or you 
can use WIN + R, then type “appwiz.cpl”. You can use the same windows to change your Windows 
features.

Programs and Features
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Working with File Explorer 

In Windows 10, we can use File Explorer in the same way as in the older Windows version to cut, 
copy, delete, paste, create shortcut, rename, view properties, and send files to other locations. You 
can open File Explorer by selecting the folder icon in the task bar or by pressing WIN + E button.

File Explorer

1.� �  �Navigation pane: From the Navigation pane, you can view your computer’s file and folder 
structure and access files and folders.

2. ��  �Forward and Back buttons: Enable you to go to folders you’ve already opened. If you go to a 
different folder, you can choose the Back button to return to the last folder you accessed.

3. �  �Ribbon: Enables you to perform layout, formatting, and sharing tasks, as well as see how File 
Explorer displays your files and folders.

4. �  �Address bar: Enables you to go to a different folder in the same Explorer window. 

5. �  �Column headings Titles of each of the columns displayed in the file and folder list.

6. �  �Search box: Allows you to search for subfolders, documents, images, programs, Web pages, 
and bookmarks in the current folder.

7. �  ��File and folder listing: Shows you the files and folders in the current folder (the folder you 
selected in the Navigation pane).

8. �  �Preview/Details pane: Enables you to quickly preview an item, such as a photo. To open the 
Preview pane, click on the View menu at the top of File Explorer, then click on the Preview pane 
button.

9. �  �Status bar: Displays information about a selected folder and its contents, such as the total 
number of items in the folder, the number of items selected and total file size.
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Additional Reading

•• https://iabdelkadir.blogspot.com.eg/2017/02/windows-10-books.html

•• http://www.arabes1.com/2015/08/windows-10-test-the-new-before-de-install.html

•• http://www.kutub.info/library/book/19420
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Chapter 3
 Microsoft Word 2016

Introduction

Microsoft Word 2016 is a word processing application inside Microsoft Office 2016 that allows you 
to create a variety of documents, including letters, resumes, and more. Word 2016 is similar to Word 
2013 and Word 2010.

 

Microsoft Word 2016
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Working with Microsoft Word Document

This module explains how to create, open, save, and close Microsoft Word documents. To do these 
operations we use the File tab. 

Working with Microsoft Word Document

How To:

•• Create a New Document: Click the File tab, select New, select a template and click the 
Create button, or you can use Ctrl + N.

•• Open a Document: Click the File tab and select Open, then browse to your file path, or 
Press Ctrl + O.

•• Save a Document: Click the Save button on the Quick Access Toolbar, or press Ctrl + S. Or 
you can use Save As to save the document with another name or file format, or press F12.

•• Print or Preview a Document: Click the File tab and select Print, or press Ctrl + P.

•• Send your Document as Email or Save it in the Cloud: Click File tab and select Share.

•• Export Document to another format: Click File tab and select Export.	Close Document: 
Click File tab and select Close, or press Ctrl + W or Ctrl + F4.

 
   Lab Exercise: Create a Microsoft Word Document

The Ribbon

This module explains how to work with the Ribbon in Microsoft Word. It’s where a majority of 
Word’s commands exist and where settings are made. These items appear as buttons, input boxes, 
and menus. The Ribbon is divided into tabs. Each tab holds separate groups. Within the groups, you 
will find the command you need.
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How To:

•• Use the Ribbon: First click a tab. Then locate the command you need by scanning the 
group names, and then finding the button. Click the button to activate the command or to 
display a menu from which you can choose a command.

•• Some items on the Ribbon let you input text or values, or make other settings.

•• Galleries on the Ribbon display a smattering of tiles. To see them all, click the Show Gallery 
button in the lower-right corner of the gallery.

•• Use the dialog box launcher icon in the lower-right corner of a group to open a dialog box 
relevant to the group’s function. 

 
    Lab Exercise: Explore the Ribbon

The Backstage View (The File Menu)

This module explains how to work with the many features located in the Backstage view. After you 
click the File tab, you can see the Microsoft Office Backstage view. The Office Backstage view is 
where you manage your files and the data about them such as their creation, saving, inspecting for 
hidden metadata or personal information, and setting options. In short, it is everything that you do 
to a file that you do not do in the file. By clicking the File tab and selecting any command, you will 
find extra options for each command that is the Backstage view.

    Lab Exercises: Open Document, New Document, and Print a Document

Formatting Microsoft Word Documents

This module explains how to work with formatting in Microsoft Word.

How To:

•• Format Text: Use the commands in the Font group on the Home tab, or select the text, 
then press Ctrl + Shift + P to change the font, font size, color and style, etc.

•• Copy Formatting: Select the text with the formatting you want to copy and click Format 
Painter  in the Clipboard group on the Home tab, or press Ctrl + Shift + C. 
Then select the  text you want to apply the copied format to, or press Ctrl + Shift + V.

•• Indent a Paragraph: Click the Increase Indent button   in the Paragraph group on the 
Home tab.

•• Decrease an Indent: Click the Decrease Indent button   in the Paragraph group on the 
Home tab.
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•• Create a Bulleted or Numbered List: Select the paragraph you want to bullet or number 
and click the Bullets   or Numbering  button in the Paragraph group on the 
Home tab.

•• Change Page Orientation: Click the Page Layout tab on the Ribbon, click the Orientation 
button   in the Page Setup group, and select an option from the list.  

    �Lab Exercises: Working with Fonts, Working with Paragraphs, Working with Bullets and 
Numbering

Microsoft Word Keyboard Shortcuts

This module shows multiple keyboard shortcuts in Microsoft Word so you can work faster. 

General

•• Open a Document		  Ctrl + O

•• Create New Document	 Ctrl + N

•• Save a Document		  Ctrl + S

•• Save As Document		  F12

•• Print a Document		  Ctrl + P

•• Close a Document		  Ctrl + W

•• Help				    F1

Editing

•• Cut				    Ctrl + X

•• Copy				    Ctrl + C

•• Paste				   Ctrl + V

•• Undo				   Ctrl + Z

•• Redo or Repeat		  Ctrl + Y

Formatting

•• Bold				    Ctrl + B

•• Italics				   Ctrl + I

•• Underline			   Ctrl + U

•• Align Left			   Ctrl + L

•• Center			   Ctrl + E

•• Align Right			   Ctrl + R

•• Justify			   Ctrl + J



COMPUTER BASICS

21Chapter 3

•• Copy Format			  Ctrl + Shift + C

•• Paste Format			  Ctrl + Shift + V

Navigation

•• Up One screen		  Page Up

•• Down One Screen		  Page Down

•• Beginning of the Line	 Home

•• End of Line			   End

•• Beginning of Document	 Ctrl + Home

•• End of Document		  Ctrl + End

•• Go To				   F5 or Ctrl + G

•• Find				    Ctrl + F

•• Replace			   Ctrl + H

Select

•• Select All			   Ctrl + A

•• Select Line up		  Shift + UP

•• Select to Paragraph Start	 Ctrl + Shift + Up

•• Select Line Down		  Shift + Down

•• Select to Paragraph End	 Ctrl + Shift + Down

•• Select Next Word 		  Ctrl + Shift + Right

•• Select Previous word	 Ctrl + Shift + Left

    Lab Exercise: Working with Keyboard Shortcuts   

Additional Reading

•• http://www.arabefuture.com/2017/02/create-booklets-using-microsoft-word-2016.html

•• http://111000.net/office/word/word2007v/158-wordv/719-word2016in1h

•• http://download-internet-pdf-ebooks.com/48-1-library-books
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Chapter 4 
Microsoft Excel 2016

Introduction 

Microsoft Excel is one of the most popular spreadsheet applications that helps you manage data, 
create visually persuasive charts, and produce thought-provoking graphs. Excel is supported by 
both Mac and PC platforms. Microsoft Excel can also be used to balance a checkbook and create an 
expense report as well as build and edit formulas.

Microsoft Excel 2016

Microsoft Excel 2016 and Microsoft Word 2016

Because Excel and Word 2016 have a very similar interface, the same Backstage view, and a 
similar Ribbon, we will use the same knowledge about Microsoft Word 2016 to start working with 
Microsoft Excel 2016. 

An Excel workbook contains multiple worksheets, and each worksheet is composed of rows and 
columns, with each row intersecting each column in a cell. These cells are referenced by column 
letter and row number, such as A1, A2, B1, B2, and so on. 

   Lab Exercise: Working with Microsoft Excel 2016 file
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Creating a Microsoft Excel Worksheet

This module explains how to create worksheets in Microsoft Excel.

 

Microsoft Excel Worksheet

How To:

•• Add or Delete Worksheets: Right click on the worksheet name as shown in the above 
figure and select Insert or Delete. (You can add a new worksheet by pressing the + sign at 
the left corner of the figure).

•• Copy or Move Worksheets: Right click on the worksheet and select Move or Copy. 

•• Change the Order of Worksheets: Drag the worksheet to the new place.

    
  Lab Exercise: Creating a Microsoft Excel Worksheet

Entering Data in Microsoft Excel Worksheets

This module explains how to how to enter data in Excel worksheets.

 

Delete and Format Cell

How To:

•• Enter Text: Select the cell and start to write.

•• Expand Data Across Columns: Select multiple cells in the same row and press  on the 
Home tab.
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•• Add and Delete Cells: Select the cell and right click on it. To add a new cell, press Insert 
and then select the proper action (Shift cells right, Shift cells down, Entire row or Entire 
column). To delete a cell, press Delete and select the proper action (Shift cells left, Shift 
cells up, Entire row or Entire column).

•• Add an Outline: Select cells to which you want to add an outline and then select the   
Borders button from the Home tab.

•• Use Auto Complete: Select the cells you want to auto complete and from the left corner 
drag down.

     �Lab Exercise: Entering Data in Microsoft Excel Worksheets, Entering Text and Using Auto 
Complete, Entering Numbers and Dates

Using Formulas in Microsoft Excel

This module explains how to use formulas in Excel.

How To:

•• Perform Math Operations and the Order of Operations: To add a math operation 
in the cell you must start the formula with the = sign and write the formula taking into 
consideration:

                                  1.  Parentheses – operations contained in parentheses are executed first

                                  2.  Exponents – exponents are executed second

                                  3.  Multiplication / Division

                                  4.  Addition / Subtraction

•• AutoSum (and Other Common Auto-Formulas): Select a cell next to the numbers you 
want to sum, click AutoSum   on the Home tab, press Enter.

•• Copy Formulas and Functions: Select the cell that contains the formula you wish to copy. 
On the HOME tab, in the Clipboard group, click Copy    command; select the cell 
into which you wish to copy the formula. On the HOME tab in the Clipboard group, click  
Paste    command.

•• Distinguish Relative and Absolute Cell References: There are two types of cell 
references: relative and absolute. Relative and absolute references behave differently 
when copied and filled into other cells. Relative references change when a formula is 
copied to another cell such as (A2- B5- etc.). Absolute references, on the other hand, 
remain constant, no matter where they are copied ($A$2 “The column and the row do not 
change when copied,” A$2 “The row does not change when copied,” $A2 “The column does 
not change when copied.”)
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Example: 

 

Using Formula in Microsoft Excel 2016

    
    Lab Exercises: Using Formulas in Microsoft Excel, Working with Formulas

  

Additional Reading

•• https://www.youtube.com/playlist?list=PL4nZcwxRcuFRtphCFtM1KMxenJLv1rGd-

•• http://download-internet-pdf-ebooks.com/49-1-library-books

•• http://www.engineers-house.com/category/tutorials/excel-2016-tutorials-in-arabic/
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Chapter 5 
Microsoft PowerPoint 2016

Introduction 

PowerPoint is a presentation program that allows you to create dynamic slide presentations 
that can include animation, narration, images, and videos for lectures, business meetings, 
advertisements, and more. With it, you can also make a single-page presentation for 
advertisements, flyers, posters, or postcards.

   

Microsoft PowerPoint 2016

Microsoft PowerPoint 2016 and Microsoft Word 2016

PowerPoint and Word 2016 have a very similar interface, with the same Backstage view and a 
similar Ribbon, so we can use the same basis of knowledge from Microsoft Word 2016 to start 
working with Microsoft PowerPoint 2016. 

Formatting Microsoft PowerPoint Presentations

This module explains how to work with formatting features in Microsoft PowerPoint presentations.



28

COMPUTER BASICS

How To:

•• Select a Slide Layout: In Normal view, on the Home tab, click Layout , then 
select a slide layout for your presentation.

•• Add New Slide: On the Home tab, click New Slide  and select the preferred slide 
layout.

•• Adding text: On the Insert tab, in the Text group, click Text Box  . Click in the document, 
and then drag to draw the text box the size that you want. To add text to a text box, click 
inside the text box, and then type or paste text. 

•• Adding Text from a Text File or Word Outline: On the Home tab, click New Slide . Click 
Slides from Outline. Locate and double-click the Word file (.doc or .docx) that contains the 
outline that you want to insert in your presentation. The file opens in PowerPoint.

•• Formatting Text as WordArt: Select a text box, or select some text inside of the text 
box. The Format tab will appear. On the Format tab, click the Text Effects command in 
the WordArt Styles group. A drop-down menu will appear showing the different effect 
categories. The effect will be applied to your text.

•• Creating Bulleted and Numbered Lists: On the View tab, click Normal. Click in the text 
box or placeholder where you want to add bulleted or numbered text. On the Home 
tab, in the Paragraph group, click Bullets or Numbering, and begin typing your list. Press 
Return to create a new list item.

•• Arranging Slides: To arrange the order of slides, in the pane on the left, click the 
thumbnail of the slide that you want to move, and then drag it to the new location. Tip: To 
select multiple slides, press and hold the Command key while you click each slide that you 
want to move, and then drag them as a group to the new location.

   Lab Exercise: Formatting Text

Inserting Images and Illustrations

This module explains how to insert images and illustrations in Microsoft PowerPoint.

How To:

 Insert Images and basic Illustrations

•• Add Images or Illustrations to a Slide: Select the Insert tab, then click on the commands 
that appear.

•• Pictures: Browse your computer to insert a saved image.
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•• Online Pictures: Allows you to insert online images using clouding or Bing Image Search. 

•• Screenshot: An easy way to add one of your available windows from your desktop.

•• Photo Album: For inserting many photographs into a presentation all at once.

•• Shapes: Squares, circles, arrows and more can be added to your slide from here.

•• SmartArt: Allows you to communicate information with graphics using different styles. 

•• Chart: Allows you to add a chart directly to your slide.

Working with Images

This module explains how to work with images in Microsoft PowerPoint.

How To:

By selecting Images, the Format tab will appear. 

 

•• Remove Background: It will automatically select the area you want to keep or remove. 
Make your selection and press Keep Changes to save or Discard All Changes to cancel. 

•• Correction: This tool helps to adjust the Sharpen/Soften and Brightness/Contrast of your 
image without using complicated software. 

•• Color: You can change your image Color Saturation, Color Tone, or Recolor using this easy 
tool.

•• Artistic Effects: This applies filters to the image to make it look more like a sketch or 
painting.

•• Compress Picture: This tool can decrease the image size but you cannot use it if the 
image has any Artistic Effects applied to it.

•• Change Picture: You can change to a new picture from here but keep the style and effects 
from the old picture.

•• Reset Picture: This will undo all changes in your picture style, size, or both.

•• Picture Style: This provides combinations of shapes, borders, and shadows to apply to 
your pictures with one click.

•• Picture Border: This changes your picture border color.

•• Picture Effects: Preset, Shadow, Reflection, Glow, Soft Edges, Bevel, and 3-D rotation; all 
these picture effects can be applied to your picture.

•• Picture Layout: This option can combine your picture with text in many layouts with one 
click, to change your presentation style.

•• Bring Forward: In this option, you can change the picture order of stacked objects by 
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using Bring Forward to change just one level or Bring to Front to place image in front of 
all other objects.

•• Send Backward: You can change the picture order of stacked objects by using Send 
Backward to go just one level back or Send to Back to place the picture behind all other 
objects.

•• Align: This option can change the placement of an object on the page—left, center, right, 
top, middle, or bottom. If you select multiple objects you can align them relative to one 
another. 

•• Group: In this option, you can join multiple objects together to move or format them as if 
they were a single object.

•• Rotate: With this option, you can rotate an object right or left, and you can flip it 
horizontally or vertically.

•• Crop: To remove an unwanted area of your picture use this option and remove it manually, 
or use Crop to Shape to crop a picture to one of various basic shapes. If you want to 
change the image size to a standard size, use Aspect Ratio. Fill and Fit are also useful 
options to change your picture size relative to your area.

•• Height: Change the height of your object.

•• Width: Change the width of your object.

    Lab Exercise: Working with Images and Shapes

Additional Reading

•• https://www.youtube.com/watch?v=uJHTi1TA91w

•• http://download-internet-pdf-ebooks.com/50-1-library-books
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Chapter 6 
Information Technology and Network Types

Introduction

In the current information technology era, it is rare to have a stand-alone computer. Most 
computers are connected to other computers through some form of network. This connection 
between computers is important in order to reduce the time, effort, and cost by allowing the 
sharing of information and resources.

                                	Stand-alone Computer  

                                                                                                    Local-area Networked Computers   

                

                                                                                                                                                         

Network Types

One of the most common network categorizations is based on scope and scale, while other 
categorizations are based on the network implementations. In this manual, we will discuss some 
important network terminology such as LAN, WAN, WLAN, intranet, extranet, Internet, and VPN.

Local Area Network 

A local-area network (LAN) connects network devices in a small area, such as a home, company, 
hospital, or school. These are all places that can easily use cable and Wi-Fi to connect. The image on 
the right above represents a LAN configuration.
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Wide Area Network
A wide-area network (WAN) connects network devices
in a wide area. This may mean connections between
different buildings, cities, or even countries. It uses
more complicated connection types than LAN.

 

                                                                                                                                                              Wide-area Network

Wireless Local Area Network (WLAN)
WLAN connects network devices using wireless
technologies such as Wi-Fi.

 
                                                                                                                                        Wireless Local-area Network 

Intranet
An intranet is a network, usually implemented 
over a private LAN, that allows use of shared
resources—such as a central database, internal 
mail server, and web application—but does not 
allow use from outside the organization.

							       		 Intranet
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Extranet

Extranet is very similar to intranet, but it is implemented over a private WAN to support the 
demands of business organizations. It can operate between buildings, cities, and countries.

 

Extranet

Internet

The Internet is the system of global connections between all computer types around the world. 
It is a network of networks that connects all users around the globe to each other. It supports the 
continuous transfers of information, images, voice, multimedia, streaming; and so on, and has 
become an important and ubiquitous source of knowledge.

 

Internet

Virtual Private Network (VPN)

VPN is a virtual connection over the Internet that can be used to communicate among private 
networks. It can securely connect multiple branches of a business organization around the globe 
using encrypted protocols to ensure privacy.
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Additional Reading

•• https://www.youtube.com/watch?v=-FjS4jEtdkA

•• http://download-internet-pdf-ebooks.com/5-1-library-books

•• http://www.kutub.info/library/category/5

•• http://www.egylearn.com/learn-network/
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Chapter 7 
Web Search Engines

Introduction 

A web search engine is a program or system of software that searches the Internet using search 
terms specified by the user and then presents the user with a listing of pertinent web pages found 
by the search engine. Ideally, the results are listed in order of relevance to the user’s query.

List of Search Engines

While many search engines are available to you, we will discuss Google in this course. However, it 
is important to be familiar with other search engines as well, since Google may not work in some 
countries.

•• Google.com

•• Bing. com

•• Yahoo.com

•• Baidu.com

•• Ask.com

•• AOL.com

Google

Google is likely the best and most popular search engine in the world. In this course, we will learn 
many tips that can make using Google very simple.

Browse to Google

Open your Internet Explorer and type www.google.com in the address bar, or just type google + 
Ctrl + Tab, and you will be redirected to the Google server in your country.

 

Google
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Use the Tabs

When you start to search, some tabs will appear that you can use to search specific fields, such as 
images, videos, news, maps, books, or personal. You can also leave it to default on “All” for a search 
of all fields.

Google Tabs

Spell Check

Even if you make a spelling error, Google can usually figure out what you mean, if your word is 
close, and give you suggestions for your search criteria.

 

Google Spell Check

Use Quotation Marks to Search for an Exact Phrase

If you want to search for an exact phrase or sentence, use quotation marks around those words. For 
example, if you want to search for Egypt Ministry of Health and Population (MOHP) as one term, 
write it as “Egypt Ministry of Health and Population.”

 

Use Quotes
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Use an Asterisk within Quotation Marks

If you want to search for a phrase or sentence but want to allow some variations, you can use 
quotation marks and replace the variable word with an asterisk (*). For example, you can use “* 
ministry of health and population” to search about any country’s ministry of health and population.

 

Use Asterisk within Quotes

Use a Hyphen to Exclude Words

Sometimes you wish to search for a certain word but you want to exclude some results. In this 
case, you can use a hyphen (-) and then the result you want to exclude. For example, if you want to 
search the MOHP but you do not want to get news results, you can use “MOHP – news”.

 

Use Hyphen



38

COMPUTER BASICS

Use a Colon to Search Specific Sites

If you need to search for any word on a certain website, you can use a colon after your search 
criteria and followed by the website address. For example, if you want to search for MOHP in cnn.
com, just write your search as “MOHP: cnn.com”.

Use Colon

Use “define:” to Find a Word’s Meaning 

If you need to search for the meaning of a word, use “define:” and your word to search for it in 
a dictionary. For example, to search for the definition of the word “organization,” use “Define: 
organization”.

Use DEFINE:

Search Images 

This is a very helpful tool that allows you to search for a specific image. Just go to Image tab and 
press the camera icon and upload your image or paste the image’s URL. 

 

 
Search Images 
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Search by Voice

Google also allows you to search without writing the search criteria. Just use the Mic icon and 
speak. (Note: your microphone must be connected and enabled.)

Search by Voice

Find a Specific File Type

To get your search results in a specific file format, use your search criteria: filetype:pdf. For example, 
to get MOHP search results in pdf format, use “MOHP:PDF”.

 

Specific File Type

Convert Money and Units

Google can find an exchange rate or unit conversion for you quickly. To get the exchange rate for 
U.S. dollars to Egyptian pounds, just enter USD to EGB, or Fahrenheit to Celsius to covert between 
temperature units. It is an easy way to convert from any unit of measure to another.

Money and Units
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Solve Mathematical Equations 

Google can solve your mathematical equation; all you have to do is ask. For example, to find the 
result of (√225+33)/12, just enter “(sqrt(225) + 33)/12”.

 

Solve Mathematical Equations

    Lab Exercise: Try to use all Google tips in this lesson
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Chapter 8 
Social Media

Introduction 

Social media has created a new era of personal and business online communication that allows 
people to share photos, feelings, career interests, places, experiences, and ideas through outlets 
such as Facebook, Twitter, Google+, LinkedIn, Instagram, and Wikipedia.

Facebook
Facebook is one of the most popular social network
websites. It allows users to post photos and videos,
send messages, send files, and chat with others.
They can also share their locations and emotions,
discuss current live events, make comments on
other pages, and browse between groups and pages.    

                                                                                                                                       Facebook 

Twitter
Twitter is a microblogging service through which
users can broadcast short messages, or “tweets,”
to their followers, who are able to read the tweets
as soon as they are posted. Celebrities and bloggers
often use it to publish their views, feelings, and
comments on current events or anything else that
catches their interest.

                                                                                                                                      LinkedIn Twitter

Google+
Google Plus (Google+) is the Internet-based social
network of Google. Google+ replaced groups with
“Circles” and chats with what they call “Hangouts.”
It uses the same Google account that you use in
Gmail or in your Android smartphone.  

            

                                                                                                              Google+



42

COMPUTER BASICS

LinkedIn 

LinkedIn is a social network developed 
specifically for the business and employment 
community. The goal of the site is to allow 
registered members to establish and document 
networks of people they know and trust 
professionally. Employers can post jobs and job 
seekers can post their CVs.

 
LinkedIn

Instagram 
Instagram is a popular mobile and Internet-based
application and service through which you can
publicly and privately share photos and videos.
You can create a separate account on Instagram
or use your Facebook account to login.

                                                                                                                                         Instagram

Wikipedia 
Wikipedia is a free online encyclopedia, created
and edited by volunteers around the world and
hosted by the Wikimedia Foundation.

 

                                                                                                                                                     Wikipedia

   Lab Exercise: Create an account on Facebook and Twitter and try to use them
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